【工程's】BarChart Factory:よくある質問

変更日 水, 16 9月 で 9:08 午前

※「Orario」はウェッブアイ製品のマスター・ブランドです。

「工程's Orario」を「工程's」、「BarChart Factory Orario」を「BarChart Factory」 と記載いたします。 


本記事では、BarChart Factoryでよくある質問を項目ごとに分けてご紹介いたします。

※BarChart Factoryのご紹介と作成については、以下の記事をご覧ください。

【工程's】BarChart Factoryのご紹介

【工程's】BarChart Factoryの作成


【目次】よくある質問

1)見た目・レイアウトを整えたい

■図形やテキスト枠の位置を揃えてきれいに配置したい

■工程表のグループとBarChart Factoryの表の幅を合わせたい

■オブジェクトに文字を入力すると文字が切れてしまう

■画像の縦横比を保ったまま拡大・縮小したい

2)PDFに出力したい・別ファイルへオブジェクトをコピーしたい

■BarChart FactoryからPDFに出力したい

■別のBarChart Factoryファイルから画像や図形などをコピー&ペーストしたい

3)印刷・出力がうまくいかないとき

■「プロジェクト名」や「日付」を自動で反映できるようにしたい

■印刷時に「印刷パターンファイルをオープンできません」と表示されて印刷できない

■印刷時に「EMF枠:なし」と表示されて印刷できない

<もっと便利に使いたい方へ>

4)テンプレートを使いたい・工程表作成を依頼したい

■すぐに使えるテンプレートを利用したい

■既存の帳票をBarChart Factoryに変換してほしい


1)見た目・レイアウトを整えたい

図形やテキスト枠の配置、幅やサイズの調整など、工程表の見た目をきれいに整える方法をご紹介します。


■図形やテキスト枠の位置を揃えてきれいに配置したい

グリッド線や整列ツールを活用することで、手作業での微調整を減らし、きれいに配置できます。


方法1:グリッド線に合わせてオブジェクトを配置する

グリッド線を表示すると、背景に[グリッドサイズ]で指定した間隔で点線が表示されます。

また、[グリッド線に合わせて配置]にチェックを入れると、オブジェクトをグリッド線に沿って配置できます。

※グリッド線の詳細は、以下の記事をご覧ください。

【工程's】BarChart Factoryの作成>■グリッド線


方法2:ツールボタンを使用してオブジェクトを整列させる

揃えたい複数のオブジェクトを範囲選択し、ツールバーの「左揃え」「上揃え」などのボタンを使うことで、オブジェクトを整列させることができます。

※上図は「上揃え」を実行し、「管理事務所」のオブジェクトの上端を基準に揃えたものです。


【手順】

1.キーボードの[Ctrl]キーを押したまま、位置を揃えたい複数の図形やテキスト枠を順番にクリックします(※選択されたオブジェクトの周りに枠マークが表示されます)


2.画面上部のツールバーにある、整列ボタンの中から任意の揃え方を選択すると、選択したオブジェクト同士のラインが均等に整列されます

ツールボタン
名称
説明
左揃え選択したすべてのオブジェクトの左端を、一番左にあるオブジェクトのラインに合わせます。
左右中央揃え選択したすべてのオブジェクトの左右の真ん中(中心軸)を、縦一直線に揃えます。
右揃え選択したすべてのオブジェクトの右端を、一番右にあるオブジェクトのラインに合わせます。
上揃え選択したすべてのオブジェクトの上端を、一番上にあるオブジェクトのラインに合わせます。
上下中央揃え選択したすべてのオブジェクトの上下の真ん中(中心軸)を、横一直線に揃えます。
下揃え選択したすべてのオブジェクトの「下端」を、一番下にあるオブジェクトのラインに合わせます。


方法3:プロパティで数値指定する

対象オブジェクトを右クリック>[プロパティ]を開き、サイズ(幅・高さ)や位置(横・縦位置)をミリ単位の数値で直接入力することで、オブジェクトをきれいに配置することができます。

※プロパティで数値指定する方法の詳細は、以下の記事をご覧ください。

【工程's】BarChart Factory:図形のプロパティ>3)図形の位置・サイズを数値で設定したい 


■工程表のグループとBarChart Factoryの表の幅を合わせたい

工程表の「グループの幅」とBarChart Factoryの「表の幅」を同じ数値に設定することで、幅を揃えて出力できます。


【手順】

1.出力したいBarChart Factoryのファイルを開きます


2.工程表の「グループの幅」と合わせたいオブジェクト(上部の見出し枠など)の上で右クリックし、表示されるメニューから[プロパティ]を選択します


3.プロパティ設定画面の中にある、[位置・サイズ]タブの[幅(W)]に入力されている数値を確認し、プロパティの画面を閉じます


4.BarChart Factoryのファイルを閉じます

※必要に応じて上書き保存をしてください。


5.出力したい工程'sのファイルを開き、工程's画面上部[ファイル] メニュー >「印刷」をクリックし、[工程図出力ウィザード] を開き、出力先に [BarChart Factory Orario] を選択して画面を進めます


6.[工程図出力ウィザード] を最後の[オプション]画面まで進めます

※[工程図出力ウィザード - オプション]の詳細は、以下の記事をご覧ください。

【工程's】印刷オプションの設定


7.画面左側の[グループ名称エリアを描画する]にチェックを入れ、その下にある[幅]のラジオボタンにもチェックを入れます


8.[幅]の横にある数値入力欄に、手順3.で確認した数値をキーボードで直接入力し、右下の「完了」ボタンをクリックすると、工程表の「グループの幅」とBarChart Factoryの「表の幅」を揃えて出力することができます


■オブジェクトに文字を入力すると文字が切れてしまう

枠内の上下左右の余白を小さく設定することで、枠サイズを変えずに文字を収めやすくなります。


【手順】

1.対象のオブジェクトを右クリック>[プロパティ]を開きます


2.プロパティ設定画面の中にある、[書式]タブ>[文字の余白]の[上][下][左][右]の数値をすべて「0」(または小さな値)に変更します

※余白を小さくしても文字が切れてしまう場合は、枠を少し広げるか、フォントサイズを小さく調整してください。


■画像の縦横比を保ったまま拡大・縮小したい

[Shift]キーを押しながら拡大・縮小することで、画像の縦横比を保てます。


【手順】

1.拡大縮小したい画像オブジェクトを左クリックで選択します


2.四隅にあるハンドル(〇)を、キーボードの[Shift]キーを押しながらマウスでドラッグして拡大縮小することで、縦横の比率がロックされ、画像が歪むのを防ぐことができます



2)PDFに出力したい・別ファイルへオブジェクトをコピーしたい

PDFへの出力や、別のファイルからのオブジェクトのコピーなど、ファイルの操作・出力方法をご紹介します。


■BarChart FactoryからPDFに出力したい

BarChart Factoryの画面で[ファイル]メニュー>[印刷]を開き、[プリンター名]のプルダウンからPDFソフトを選択して印刷を実行すると、PDFファイルとして保存できます。

※BarChart FactoryからPDFに出力する方法は、以下の記事をご覧ください。

【工程's】工程表をPDFで出力したい>2)BarChart Factory(帳票)を使用して工程表をPDFで出力する方法


■別のBarChart Factoryファイルから画像や図形などをコピー&ペーストしたい

同じウィンドウで開いて操作することで、画像や図形などをコピー&ペーストできます。


【手順】

1.コピー元のBarChart Factoryを開きます

(貼り付け先のBarChart Factoryを開いている場合は閉じます)


2.コピー元のBarChart Factoryで、コピーしたい画像や図形をコピーします(キーボードの[Ctrl]+[C])


3.BarChart Factory画面上部にある[ファイル]メニュー> [開く]をクリックし、貼り付け先のBarChart Factoryファイルを選択して開きます


4.貼り付け先のBarChart Factoryが開かれるため、貼り付けします(キーボードの[Ctrl]+[V])



3)印刷・出力がうまくいかないとき

プロジェクト名や日付が反映されない、印刷を進められないときなどの対処方法をご紹介します。


■「プロジェクト名」や「日付」を自動で反映できるようにしたい

「フィールド枠」をご活用いただくことで、「プロジェクト名」や「日付」などを手入力せずに、工程表の情報を反映できます。

※フィールド枠の詳細は、以下の記事をご覧ください。

【工程's】BarChart Factoryの作成>・フィールド枠


■印刷時に「印刷パターンファイルをオープンできません」と表示されて印刷できない

選択したBarChart Factoryファイルを開いていることが原因です。BarChart Factoryファイルを閉じることで印刷できます。


【手順】

1.現在、画面上やタスクバーに「BarChart Factory」のウィンドウが起動していないか確認します


2.起動しているBarChart Factoryファイルを閉じます

※必要に応じて上書き保存をしてください。


3.工程'sの[工程図出力 ウィザード]を開き、該当のBarChart Factoryファイルを選択します


4.エラーメッセージが消え、「次へ」もしくは「完了」ボタンがクリックできるようになります


■印刷時に「EMF枠:なし」と表示されて印刷できない

BarChart Factoryに「工程表枠」が作成されていないことが原因です。

「工程表枠」を作成することで、エラーを解消して工程表を印刷できます。


【手順】

1.該当の印刷パターンファイル(拡張子が .bcfx または .bcf のファイル)を、BarChart Factoryで起動して編集画面を開きます


2.画面上部のツールバーにある「工程表枠」のアイコンをクリックします


3.マウスをシート上で斜めにドラッグし、工程表を表示させたい範囲に枠を作成します

※枠を作成することで、画面上に工程表データを描画するためのスペースが確保されます。


4.[ファイル]メニュー>[上書き保存]で印刷パターンファイルを保存し、BarChart Factoryのアプリケーションを終了します

※BarChart Factoryのファイルが開いたまま(編集中)になっている場合、印刷ができません。


5.工程'sで「印刷」>[工程図出力ウィザード]を再度実行し、修正した印刷パターンファイルを選択して出力します


6.作成した枠の中に、工程表データが表示されます



4)テンプレートを使いたい・工程表作成を依頼したい

すぐに活用できるテンプレートをご用意しています。

また、既存の帳票をBarChart Factoryで利用できる形式に変換する「工程表変換サービス」もご利用いただけます。


■すぐに使えるテンプレートを利用したい

テンプレートを活用することで、帳票を効率的に作成できます。
用途に応じて、帳票作成にご活用ください。


・清水建設様専用テンプレート

清水建設様の土木イントラネットの工程'sページでは、月間工程表および週間工程表のBarChart Factoryテンプレートを公開しています。
土木イントラネット 工程'sページ:
https://shimz.sharepoint.com/sites/CIM_promotion_group_site/SitePages/%E5%B7%A5%E7%A8%8B%E2%80%99%EF%BD%93.aspx


・工程's標準搭載テンプレート

工程'sには、BarChart Factoryのテンプレートが標準搭載されています。
BarChart Factory 画面の[ファイル]メニュー>「新規作成」から、テンプレートファイルを選択してご利用いただけます。


■既存の帳票をBarChart Factoryに変換してほしい

工程表変換サービスでは、工程'sファイルへの変換だけでなくBarChart Factoryの作成も承っております。

※工程表変換サービスのサンプルやご依頼方法の詳細は、以下の記事をご覧ください。

【工程's】工程表変換サービスのご紹介



是非ご活用ください!


この記事は役に立ちましたか?

それは素晴らしい!

フィードバックありがとうございます

お役に立てず申し訳ございません!

フィードバックありがとうございます

この記事に改善できることがあれば教えてください。

少なくとも一つの理由を選択してください
CAPTCHA認証が必要です。

フィードバックを送信しました

記事の改善におけるご協力ありがとうございます。